MISTAR Slowness

Incident Report for Wayne RESA Statuspage

Resolved

We rebooted the servers to resolve the slowness issue and are reviewing logs to see if there is anything that helps determine root cause.
Posted Sep 10, 2026 - 10:12 EDT

Investigating

We have received support tickets and calls from some districts about slowness in accessing MISTAR. We are actively investigating the issue.
Posted Sep 09, 2026 - 09:56 EDT
This incident affected: Student Applications (MISTAR, MISTAR - Student Connect, MISTAR - Parent Connect).